update setup.py with new version number, new py requirements
authorThomas Waldmann <tw AT waldmann-edv DOT de>
Sun, 19 May 2013 20:39:47 +0200
changeset 101a8c36202d0da
parent 100 9d39d4bc2deb
child 102 33e6008c6e22
update setup.py with new version number, new py requirements
setup.py
     1.1 --- a/setup.py	Sun May 19 20:37:50 2013 +0200
     1.2 +++ b/setup.py	Sun May 19 20:39:47 2013 +0200
     1.3 @@ -30,9 +30,9 @@
     1.4  
     1.5  setup(
     1.6      name="emeraldtree",
     1.7 -    version="0.9.2",
     1.8 +    version="0.10.0",
     1.9      url='http://hg.moinmo.in/EmeraldTree/',
    1.10 -    download_url = "http://static.moinmo.in/files/packages/emeraldtree-0.9.2.tar.gz",
    1.11 +    download_url = "http://static.moinmo.in/files/packages/emeraldtree-0.10.0.tar.gz",
    1.12      author="Bastian Blank",
    1.13      author_email="bblank@thinkmo.de",
    1.14      keywords=["xml", "html", "html5", "polyglot", "element", "tree", "dom", "unicode", ],
    1.15 @@ -43,12 +43,15 @@
    1.16          'Development Status :: 4 - Beta',
    1.17          'Operating System :: OS Independent',
    1.18          'Programming Language :: Python',
    1.19 +        'Programming Language :: Python :: 2.7',
    1.20 +        'Programming Language :: Python :: 3.3',
    1.21          'License :: OSI Approved :: Python Software Foundation License',
    1.22          'Intended Audience :: Developers',
    1.23          'Topic :: Text Processing :: Markup :: HTML',
    1.24          'Topic :: Text Processing :: Markup :: XML',
    1.25      ],
    1.26      packages=["emeraldtree"],
    1.27 -    platforms="Python 2.4 and later.",
    1.28 +    install_requires=['six>=1.3.0'],
    1.29 +    platforms="Python 2.7.x. and >=3.3",
    1.30  )
    1.31