annotate MoinMoin/support/README.txt @ 5562:e1e730402364

document support code version requirements
author Thomas Waldmann <tw AT waldmann-edv DOT de>
date Sun, 21 Feb 2010 23:04:37 +0100
parents 16db661e85b7
children
rev   line source
5562
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
1 3rd party python code requirements
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
2 ==================================
4285
012c4c4ce35b Added information on flup origin and modification
Florian Krupicka <florian.krupicka@googlemail.com>
parents:
diff changeset
3
5562
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
4 This file has some notes about the software we bundle and ship with MoinMoin
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
5 in the MoinMoin/support/ directory. If you are a Linux distributor and you
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
6 want to rip out this stuff and replace it with packages, this is for you!
4285
012c4c4ce35b Added information on flup origin and modification
Florian Krupicka <florian.krupicka@googlemail.com>
parents:
diff changeset
7
5562
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
8 We list the shipped version and also the minimum required version.
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
9 The shipped version will work best with moin as usually has some more bug
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
10 fixes than the minimum required version.
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
11 We do not test with the minimum required version, but we try to keep this
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
12 file updated and correct to our best knowledge.
4285
012c4c4ce35b Added information on flup origin and modification
Florian Krupicka <florian.krupicka@googlemail.com>
parents:
diff changeset
13
5562
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
14 In case you find bugs in this requirements specification, please let us know!
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
15
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
16 Thanks to all 3rd party software authors!
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
17
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
18 flup (cgi/fastcgi/scgi/ajp to WSGI adapter)
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
19 ===========================================
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
20 shipped: 1.0.2+, from repo: hg clone -r 3b07cc2b0c76 http://hg.saddi.com/flup-server
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
21 minimum: 1.0.2
4285
012c4c4ce35b Added information on flup origin and modification
Florian Krupicka <florian.krupicka@googlemail.com>
parents:
diff changeset
22
4902
6049883eb89e updated flup to 1.0.2+ (http://hg.saddi.com/flup-server changeset 100:af072c39193e)
Reimar Bauer <rb.proj AT googlemail DOT com>
parents: 4303
diff changeset
23
5562
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
24 pygments (highlighting for all sorts of source code and other text files)
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
25 =========================================================================
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
26 shipped: 1.1.1
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
27 minimum: 1.1.1(?)
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
28
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
29
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
30 parsedatetime (parse date/time strings)
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
31 =======================================
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
32 shipped: 0.8.7
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
33 minimum: 0.8.7(?)
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
34
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
35
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
36 werkzeug (WSGI toolkit)
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
37 =======================
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
38 shipped: 0.5.1
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
39 minimum: 0.5.1(?)
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
40
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
41
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
42 xappy (High-Level Python library for Xapian)
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
43 ============================================
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
44 shipped: 0.5
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
45 minimum: 0.5
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
46
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
47
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
48 htmlmarkup.py (safe html rendering)
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
49 ===================================
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
50 shipped: copied from TRAC's trac.util.html, revision 3609, merged on 2006-08-20
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
51 minimum: same(?)
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
52
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
53
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
54 Replacements for Python stdlib modules
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
55 ======================================
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
56 difflib.py (fixes broken Python 2.4.3 difflib, see comment in file)
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
57 HeaderFixed.py ("copied from email.Header because the original is broken")
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
58 tarfile.py (misc. brokenness up to Python 2.6, see comment in file)
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
59
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
60
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
61 Other stuff
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
62 ===========
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
63 BasicAuthTransport.py (taken from Amos' XML-RPC HowTo)
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
64 python_compatibility.py (to be compatible with older Pythons)
e1e730402364 document support code version requirements
Thomas Waldmann <tw AT waldmann-edv DOT de>
parents: 5561
diff changeset
65