comparison docs/CHANGES @ 5869:0e58d9bcd3bd

update docs/REQUIREMENTS about python 2.4 support, point to there from docs/CHANGES
author Thomas Waldmann <tw AT waldmann-edv DOT de>
date Fri, 03 Aug 2012 17:36:02 +0200
parents 9acfab97e561
children 2e90d7b58b42
comparison
equal deleted inserted replaced
5868:fc11712e0df0 5869:0e58d9bcd3bd
15 If you can't live with those, you can simply switch it off by using: 15 If you can't live with those, you can simply switch it off by using:
16 editor_force = True 16 editor_force = True
17 editor_default = 'text' # internal default, just for completeness 17 editor_default = 'text' # internal default, just for completeness
18 18
19 Current: 19 Current:
20
21 HINT: Python >= 2.5 is maybe required! See docs/REQUIREMENTS for details.
20 22
21 Fixes: 23 Fixes:
22 * rss_rc: Fix diffs added in RSS with diffs=1 (now they correspond to item 24 * rss_rc: Fix diffs added in RSS with diffs=1 (now they correspond to item
23 listed in feed and not just last page diffs). Links generated with ddiffs=1 25 listed in feed and not just last page diffs). Links generated with ddiffs=1
24 also fixed. 26 also fixed.
53 55
54 SECURITY HINT: make sure you have allow_xslt = False (or just do not use 56 SECURITY HINT: make sure you have allow_xslt = False (or just do not use
55 allow_xslt at all in your wiki configs, False is the internal default). 57 allow_xslt at all in your wiki configs, False is the internal default).
56 Allowing XSLT/4suite is very dangerous, see HelpOnConfiguration wiki page. 58 Allowing XSLT/4suite is very dangerous, see HelpOnConfiguration wiki page.
57 59
58 HINT: Python >= 2.5 is maybe required! 60 HINT: Python >= 2.5 is maybe required! See docs/REQUIREMENTS for details.
59 To use all the code that is bundled in the MoinMoin download release,
60 you are required to have Python >= 2.5 now. This is primarily due to
61 werkzeug 0.8 requiring it. Also, because Python 2.4 is rather rare these
62 days, moin 1.9.4 did not get tested on Python 2.4. So if you still must
63 run it on 2.4, try replacing MoinMoin/support/werkzeug with werkzeug version
64 0.7.x and hope the best. Contact us if it does not work.
65 Python requirements might be different for (linux or other) distribution
66 packages, depending on the werkzeug version they use. Usually you do
67 not have to care then, because the package maintainer already did it for you.
68 61
69 Fixes: 62 Fixes:
70 * Fix XSS / remove javascript URL support in rst parser (CVE-2011-1058). 63 * Fix XSS / remove javascript URL support in rst parser (CVE-2011-1058).
71 * werkzeug: Removed a dummy import. Fixes Python 2.7 compatibility. 64 * werkzeug: Removed a dummy import. Fixes Python 2.7 compatibility.
72 * Fix linux-to-windows edit-log migration/upgrade issue (wrong line endings) 65 * Fix linux-to-windows edit-log migration/upgrade issue (wrong line endings)