comparison docs/REQUIREMENTS @ 5869:0e58d9bcd3bd

update docs/REQUIREMENTS about python 2.4 support, point to there from docs/CHANGES
author Thomas Waldmann <tw AT waldmann-edv DOT de>
date Fri, 03 Aug 2012 17:36:02 +0200
parents 6e0a686893c3
children 0fd330339378
comparison
equal deleted inserted replaced
5868:fc11712e0df0 5869:0e58d9bcd3bd
1 Python requirements 1 Python requirements
2 =================== 2 ===================
3 3
4 Please use Python 2.6.x, 2.5.x, 2.7.x, 2.4.x (in that order, first most 4 Please use Python 2.6.x, 2.7.x, 2.5.x (in that order, first most
5 recommended, last least recommended). 5 recommended, last least recommended). See below about Python 2.4.
6 2.4 is last because it is very OLD and not much tested any more.
7 2.7 is 2nd last because it is very NEW and not much tested with moin yet.
8 6
9 Python 2.3 is not supported by moin 1.9.x (use moin 1.8.x if you can't 7 2.7 is 2nd because it is less long tested than 2.6. If you have 2.7 by default
10 upgrade Python now [but please begin planning your Python upgrade, 1.8.8 or 8 then just use it, there is usually no need to get 2.6. But if you have 2.6 by
11 1.8.9 will be the last moin 1.8.x release]). 9 default, just use that, because there is also no need to get 2.7.
10
11 2.5 is last because it is OLD and not much tested any more.
12
13 2.4 was supported "out of the box" until (and including) moin 1.9.3.
14 Since 1.9.4 the download release of moin has bundled libraries that need 2.5
15 at least. Also, no moin developer still tests moin on 2.4.
16 If you are willing to experiment a bit and use older libraries than the
17 bundled ones, you might be able to get it working on 2.4 by replacing
18 MoinMoin/support/werkzeug with werkzeug version 0.7.x and hope the best.
19 Python requirements might be different for (linux or other) distribution
20 packages, depending on the werkzeug version they use. Usually you do not have
21 to care then, because the package maintainer already did it for you.
12 22
13 Python 3.x won't work for MoinMoin for now. 23 Python 3.x won't work for MoinMoin for now.
14 24
15 Python build options: 25 Python build options:
16 * zlib support (required) 26 * zlib support (required)