comparison docs/REQUIREMENTS @ 5571:994f62ad6f84

add more requirements information
author Thomas Waldmann <tw AT waldmann-edv DOT de>
date Mon, 22 Feb 2010 11:09:54 +0100
parents e057c204d628
children f76914e77229 db8483f60775
comparison
equal deleted inserted replaced
5570:395781ee66d7 5571:994f62ad6f84
34 34
35 GUI editor: python-xml (pyxml) - more precisely, this stuff is needed by the 35 GUI editor: python-xml (pyxml) - more precisely, this stuff is needed by the
36 html to wiki markup converter invoked when the gui editor posts 36 html to wiki markup converter invoked when the gui editor posts
37 html on save. Status for python 2.5.x unknown. 37 html on save. Status for python 2.5.x unknown.
38 38
39 Docbook formatter: python-xml (pyxml). Status for python 2.5.x unknown. 39 Docbook formatter: python-xml (pyxml).
40 40
41 docbook parser: 4suite 1.0a4 or 1.0b1 41 docbook parser: 4suite 1.0a4 or 1.0b1
42 42
43 xslt parser: 4suite 1.0a4 or 1.0b1 43 xslt parser: 4suite 1.0a4 or 1.0b1
44 44
45 rst parser: docutils 0.3.10 or later 45 rst parser: docutils >= 0.3.10
46 46
47 Xapian indexed search engine:: xapian libs + python bindings >= 1.0.6 47 Xapian indexed search: xapian libs + python bindings >= 1.0.6
48 48
49 Indexing filters for xapian search: 49 Indexing filters for xapian search:
50 * antiword (for indexing of MS Word documents) 50 * antiword (for indexing of MS Word documents)
51 * xls2csv (for indexing of MS Excel documents, from catdoc package) 51 * xls2csv (for indexing of MS Excel documents, from catdoc package)
52 * catppt (for indexing of MS Powerpoint documents, from catdoc package) 52 * catppt (for indexing of MS Powerpoint documents, from catdoc package)
62 stats charts: gdchart python module 62 stats charts: gdchart python module
63 63
64 jabberbot: pyxmpp SVN revision 665 or release >= 1.0.1 64 jabberbot: pyxmpp SVN revision 665 or release >= 1.0.1
65 65
66 66
67 3rd party code requirements 67 Bundled 3rd party code
68 =========================== 68 ======================
69 69
70 Below are some notes about the software we bundle and ship with MoinMoin. 70 Below are some notes about the software we bundle and ship with MoinMoin.
71 If you are a Linux distributor and you want to rip out this stuff and 71 If you are a Linux distributor and you want to rip out this stuff and
72 replace it with packages, this is for you! 72 replace it with packages, this is for you!
73 73
91 91
92 92
93 pygments (highlighting for all sorts of source code and other text files) 93 pygments (highlighting for all sorts of source code and other text files)
94 ========================================================================= 94 =========================================================================
95 shipped: 1.2.2 95 shipped: 1.2.2
96 minimum: 1.1.1(?) 96 minimum: 1.1.1 will work, maybe even older versions
97 97
98 98
99 parsedatetime (parse date/time strings) 99 parsedatetime (parse date/time strings)
100 ======================================= 100 =======================================
101 shipped: 0.8.7 101 shipped: 0.8.7
103 103
104 104
105 werkzeug (WSGI toolkit) 105 werkzeug (WSGI toolkit)
106 ======================= 106 =======================
107 shipped: 0.5.1 107 shipped: 0.5.1
108 minimum: 0.5.1(?) 108 minimum: 0.5.1 will work, maybe 0.5 also
109 109
110 110
111 xappy (High-Level Python library for Xapian) 111 xappy (High-Level Python library for Xapian)
112 ============================================ 112 ============================================
113 shipped: 0.5 113 shipped: 0.5
142 shipped: ? 142 shipped: ?
143 required: ? 143 required: ?
144 144
145 145
146 D) MoinMoin/web/static/htdocs/applets/anywikidraw/ 146 D) MoinMoin/web/static/htdocs/applets/anywikidraw/
147 shipped: ? 147 shipped: 0.14
148 required: ? 148 required: 0.14(?)
149 149
150
151
152