diff docs/CHANGES @ 5869:0e58d9bcd3bd

update docs/REQUIREMENTS about python 2.4 support, point to there from docs/CHANGES
author Thomas Waldmann <tw AT waldmann-edv DOT de>
date Fri, 03 Aug 2012 17:36:02 +0200
parents 9acfab97e561
children 2e90d7b58b42
line wrap: on
line diff
--- a/docs/CHANGES	Sun Jul 22 20:59:35 2012 +0200
+++ b/docs/CHANGES	Fri Aug 03 17:36:02 2012 +0200
@@ -18,6 +18,8 @@
 
 Current:
 
+  HINT: Python >= 2.5 is maybe required! See docs/REQUIREMENTS for details.
+
   Fixes:
    * rss_rc: Fix diffs added in RSS with diffs=1 (now they correspond to item
      listed in feed and not just last page diffs). Links generated with ddiffs=1
@@ -55,16 +57,7 @@
   allow_xslt at all in your wiki configs, False is the internal default).
   Allowing XSLT/4suite is very dangerous, see HelpOnConfiguration wiki page.
 
-  HINT: Python >= 2.5 is maybe required!
-  To use all the code that is bundled in the MoinMoin download release,
-  you are required to have Python >= 2.5 now. This is primarily due to
-  werkzeug 0.8 requiring it. Also, because Python 2.4 is rather rare these
-  days, moin 1.9.4 did not get tested on Python 2.4. So if you still must
-  run it on 2.4, try replacing MoinMoin/support/werkzeug with werkzeug version
-  0.7.x and hope the best. Contact us if it does not work.
-  Python requirements might be different for (linux or other) distribution
-  packages, depending on the werkzeug version they use. Usually you do
-  not have to care then, because the package maintainer already did it for you.
+  HINT: Python >= 2.5 is maybe required! See docs/REQUIREMENTS for details.
 
   Fixes:
    * Fix XSS / remove javascript URL support in rst parser (CVE-2011-1058).