diff docs/REQUIREMENTS @ 5944:82ad863c255e

clarify python-xml (pyxml) requirement
author Thomas Waldmann <tw AT waldmann-edv DOT de>
date Sat, 23 Feb 2013 18:28:30 +0100
parents 25900eaeb864
children d72a5e95c7c0
line wrap: on
line diff
--- a/docs/REQUIREMENTS	Tue Feb 19 23:59:31 2013 +0100
+++ b/docs/REQUIREMENTS	Sat Feb 23 18:28:30 2013 +0100
@@ -47,14 +47,6 @@
 Requirements needed for some moin features
 ==========================================
 
-RSS feed: python-xml (pyxml) or python >= 2.5.1
-
-GUI editor: python-xml (pyxml) - more precisely, this stuff is needed by the
-            html to wiki markup converter invoked when the gui editor posts
-            html on save. Status for python 2.5.x unknown.
-
-Docbook formatter: python-xml (pyxml).
-
 docbook parser: 4suite 1.0a4 or 1.0b1
 
 xslt parser: 4suite 1.0a4 or 1.0b1
@@ -80,6 +72,13 @@
 
 jabberbot: pyxmpp SVN revision 665 or release >= 1.0.1
 
+Only if you are using some python < 2.5.1, you likely will need python-xml
+(pyxml) for some features. It should just work with python's standard library
+for more recent python versions. Features needing this:
+ * the RSS feed (action/rss_rc)
+ * GUI editor converter (converter/text_html_text_moin_wiki)
+ * docbook formatter (formatter/text_docbook)
+
 
 Bundled 3rd party code
 ======================