diff MoinMoin/_tests/ldap_testbase.py @ 4617:8a3c0c726d66

remove some references to py 2.3/2.4 - 2.4 is the minimum now anyway
author Thomas Waldmann <tw AT waldmann-edv DOT de>
date Sun, 01 Mar 2009 04:11:08 +0100
parents 07862b0663fd
children
line wrap: on
line diff
--- a/MoinMoin/_tests/ldap_testbase.py	Sun Mar 01 03:49:09 2009 +0100
+++ b/MoinMoin/_tests/ldap_testbase.py	Sun Mar 01 04:11:08 2009 +0100
@@ -32,8 +32,6 @@
 
     # /etc/init.d/apparmor stop
 
-    Requires Python 2.4 (for subprocess module).
-
     @copyright: 2008 by Thomas Waldmann
     @license: GNU GPL, see COPYING for details.
 """
@@ -44,11 +42,7 @@
 import os, shutil, tempfile, time, base64, md5
 from StringIO import StringIO
 import signal
-
-try:
-    import subprocess  # needs Python 2.4
-except ImportError:
-    subprocess = None
+import subprocess
 
 try:
     import ldap, ldif, ldap.modlist  # needs python-ldap
@@ -61,8 +55,6 @@
         Either return some failure reason if we can't or None if everything
         looks OK.
     """
-    if subprocess is None:
-        return "You need at least python 2.4 to use ldap_testbase."
     if ldap is None:
         return "You need python-ldap installed to use ldap_testbase."
     slapd = False