diff docs/CHANGES @ 3625:ef3cbfb74b2e

improve upgrading hints for the SecurityPolicy imports
author Thomas Waldmann <tw AT waldmann-edv DOT de>
date Tue, 20 May 2008 02:57:44 +0200
parents f126ec680605
children 776b338ccc2d
line wrap: on
line diff
--- a/docs/CHANGES	Mon May 19 21:13:26 2008 +0200
+++ b/docs/CHANGES	Tue May 20 02:57:44 2008 +0200
@@ -725,6 +725,11 @@
       need to use "from MoinMoin.config.multiconfig import DefaultConfig" now.
       You need to change this in your wikiconfig.py or farmconfig.py file.
       See MoinMoin/multiconfig.py for an alternative way if you can't do that.
+    * HINT: you need to change some imports (if you have them in your config):
+      Old: from MoinMoin.util.antispam import SecurityPolicy
+      New: from MoinMoin.security.antispam import SecurityPolicy
+      Old: from MoinMoin.util.autoadmin import SecurityPolicy
+      New: from MoinMoin.security.autoadmin import SecurityPolicy
     * HINT: you need to change your auth stuff, the new way is:
       from MoinMoin.auth import moin_login, moin_session
       from MoinMoin.auth.http import http
@@ -803,8 +808,6 @@
       Most stuff will be broken, please help fixing it (usually some imports
       will be missing and the adaptor script will need a change maybe):
       Tested successfully: CGI, CLI, STANDALONE, FCGI, TWISTED
-    * Moved util/antispam.py to security/antispam.py.
-    * Moved util/autoadmin.py to security/autoadmin.py.
     * Moved security.py to security/__init__.py.
     * Moved wikiacl.py to security/__init__.py.
     * Moved logfile/logfile.py to logfile/__init__.py.