view docs/REQUIREMENTS @ 6115:970be85fb9b9

update REQUIREMENTS
author Thomas Waldmann <tw AT waldmann-edv DOT de>
date Tue, 20 Sep 2016 20:39:20 +0200
parents fc1f97a47c7e
children 7f12cf241d5e
line wrap: on
line source
Python requirements
===================

You need Python 2.7.x (older Python versions are outdated, not supported and
not tested).

Python 3.x won't work for MoinMoin 1.x.x.

Python build options:
 * zlib support (required)
 * ucs4 (32bit unicode, recommended)
 * ucs2 also works for most users (not recommended)


Servers
=======
You can use anything that speaks WSGI to moin:
 * the "standalone" wikiserver.py we bundle with moin (recommended for
   desktop wikis, testing, debugging, development, adhoc-wikis)
 * apache with mod_wsgi (recommended for bigger/busier wikis), do not use
   mod_wsgi v2.3 (it has known problems), about any other version is fine.
 * other WSGI-compatible servers
 * cgi, fastcgi, scgi, ajp, ... also work via the "flup" middleware bundled with moin
 * For IIS 6.0 on Windows 2003, you can use a ISAPI-WSGI gateway:
   http://code.google.com/p/isapi-wsgi/ v0.4.1 has been used successfully.


Requirements needed for some moin features
==========================================

docbook parser: 4suite 1.0a4 or 1.0b1

xslt parser: 4suite 1.0a4 or 1.0b1

rst parser: docutils >= 0.3.10

Xapian indexed search: xapian libs + python bindings >= 1.0.6

Indexing filters for xapian search:
 * antiword (for indexing of MS Word documents)
 * xls2csv (for indexing of MS Excel documents, from catdoc package)
 * catppt (for indexing of MS Powerpoint documents, from catdoc package)
 * catdoc (for indexing of RTF documents, from catdoc package)
 * pdftotext (for indexing of PDFs, from xpdf-utils or poppler-utils)

ldap_login auth: python-ldap >=2.0.0pre06

mysql_group auth: MySQLdb python module

openidrp auth: openid python module

stats charts: gdchart python module

jabberbot: pyxmpp SVN revision 665 or release >= 1.0.1


Bundled 3rd party code
======================

Below are some notes about the software we bundle and ship with MoinMoin.
If you are a Linux distributor and you want to rip out this stuff and
replace it with packages, this is for you!

We list the shipped version and also the minimum required version.
The shipped version will work best with moin as usually has some more bug
fixes than the minimum required version.
We do not test with the minimum required version, but we try to keep this
file updated and correct to our best knowledge.

In case you find bugs in this requirements specification, please let us know!

Thanks to all 3rd party software authors!


A) Stuff below MoinMoin/support/:

passlib (password hashing library)
==================================
shipped: 1.6.5
minimum: 1.3(?)

Note: moin could work without passlib also (NOT RECOMMENDED), but would not
support stronger password hashes then, also would not be able to process such
hashes from existing user profiles (that were made with passlib) and also
would be less secure due to the weaker builtin hash methods.


flup (cgi/fastcgi/scgi/ajp to WSGI adapter)
===========================================
shipped: 1.0.2+, from repo: hg clone -r 8d52f88effa3 http://hg.saddi.com/flup-server
minimum: 1.0.2


pygments (highlighting for all sorts of source code and other text files)
=========================================================================
shipped: 2.1.3
minimum: 1.1.1 will work, maybe even older versions


parsedatetime (parse date/time strings)
=======================================
shipped: 2.1
minimum: 0.8.7(?)


werkzeug (WSGI toolkit)
=======================
shipped: 0.11.11
minimum: 0.7.0


xappy (High-Level Python library for Xapian)
============================================
shipped: 0.5
minimum: 0.5


htmlmarkup.py (safe html rendering)
===================================
shipped: copied from TRAC's trac.util.html, revision 3609, merged on 2006-08-20
minimum: same(?)


Other stuff
===========
BasicAuthTransport.py (taken from Amos' XML-RPC HowTo)
python_compatibility.py (not used by moin any more)


B) MoinMoin/web/static/htdocs/applets/FCKEditor/
shipped: 2.6.11
required: 2.6.x


C) MoinMoin/web/static/htdocs/applets/TWikiDrawPlugin/
shipped: Using a modified TWikiDrawPlugin see README in contrib/TWikiDrawPlugin 
required: see shipped


D) MoinMoin/web/static/htdocs/applets/anywikidraw/
shipped: 0.14
required: 0.14