changeset 5491:65bf6cb180b7

moin.fcgi: fix recursion error and some minor cosmetics
author Thomas Waldmann <tw AT waldmann-edv DOT de>
date Thu, 04 Feb 2010 10:01:53 +0100
parents ca71e01d845b
children e900c097a46b
files wiki/server/moin.fcgi
diffstat 1 files changed, 6 insertions(+), 6 deletions(-) [+]
line wrap: on
line diff
--- a/wiki/server/moin.fcgi	Wed Feb 03 21:19:12 2010 +0100
+++ b/wiki/server/moin.fcgi	Thu Feb 04 10:01:53 2010 +0100
@@ -1,12 +1,11 @@
 #!/usr/bin/python
 # -*- coding: utf-8 -*-
-
 """
     MoinMoin - CGI/FCGI Driver script
 
     @copyright: 2000-2005 by Juergen Hermann <jh@web.de>,
                 2008 by MoinMoin:ThomasWaldmann,
-                2008 by MoinMoin:FlorianKrupicka
+                2008 by MoinMoin:FlorianKrupicka,
                 2010 by MoinMoin:RadomirDopieralski
     @license: GNU GPL, see COPYING for details.
 """
@@ -45,9 +44,10 @@
 application = make_application(shared=True)
 
 ## Uncomment this if you need to set the SCRIPT_NAME:
-#def application(env, start):
-#    env['SCRIPT_NAME'] = ''
+#def script_fixer(env, start):
+#    env['SCRIPT_NAME'] = ''  # use '' for running at /, '/wiki' for running at /wiki/
 #    return application(env, start)
+#application = script_fixer
 
 ## Choose your server mode (threaded, forking or single-thread)
 try:
@@ -55,8 +55,8 @@
 #    from flup.server.fcgi_fork import WSGIServer
 #    from flup.server.fcgi_single import WSGIServer
 except ImportError:
-    logging.warning("No flup-package installed, only basic CGI "
-                    "support is available.")
+    logging.warning("No flup-package installed, only basic CGI support is available.")
     from MoinMoin.web._fallback_cgi import WSGIServer
 
 WSGIServer(application).run()
+