changeset 4995:77496dd99338

Xapian2009: Search tests are skipped if py version is not 1.0.0
author Dmitrijs Milajevs <dimazest@gmail.com>
date Tue, 11 Aug 2009 23:14:52 +0200
parents 605b2da7765e
children 0e4eff722cac
files MoinMoin/search/_tests/test_search.py
diffstat 1 files changed, 5 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- a/MoinMoin/search/_tests/test_search.py	Tue Aug 11 22:30:26 2009 +0200
+++ b/MoinMoin/search/_tests/test_search.py	Tue Aug 11 23:14:52 2009 +0200
@@ -15,6 +15,11 @@
 from MoinMoin.search.builtin import MoinSearch, XapianSearch
 from MoinMoin._tests import nuke_xapian_index, wikiconfig, become_trusted, create_page, nuke_page
 
+if py.version != '1.0.0':
+    # There are some generative tests, which won't run on older versions!
+    # XXX These tests should be refactored to be able to be run with older versions of py.
+    py.test.skip('Currently py version 1.0.0 is needed')
+
 
 class TestQueryParsing(object):
     """ search: query parser tests """