changeset 4617:8a3c0c726d66

remove some references to py 2.3/2.4 - 2.4 is the minimum now anyway
author Thomas Waldmann <tw AT waldmann-edv DOT de>
date Sun, 01 Mar 2009 04:11:08 +0100
parents 995e39af3f7c
children 0e7c007f8ed9
files MoinMoin/_tests/ldap_testbase.py MoinMoin/auth/smb_mount.py MoinMoin/theme/__init__.py
diffstat 3 files changed, 2 insertions(+), 12 deletions(-) [+]
line wrap: on
line diff
--- a/MoinMoin/_tests/ldap_testbase.py	Sun Mar 01 03:49:09 2009 +0100
+++ b/MoinMoin/_tests/ldap_testbase.py	Sun Mar 01 04:11:08 2009 +0100
@@ -32,8 +32,6 @@
 
     # /etc/init.d/apparmor stop
 
-    Requires Python 2.4 (for subprocess module).
-
     @copyright: 2008 by Thomas Waldmann
     @license: GNU GPL, see COPYING for details.
 """
@@ -44,11 +42,7 @@
 import os, shutil, tempfile, time, base64, md5
 from StringIO import StringIO
 import signal
-
-try:
-    import subprocess  # needs Python 2.4
-except ImportError:
-    subprocess = None
+import subprocess
 
 try:
     import ldap, ldif, ldap.modlist  # needs python-ldap
@@ -61,8 +55,6 @@
         Either return some failure reason if we can't or None if everything
         looks OK.
     """
-    if subprocess is None:
-        return "You need at least python 2.4 to use ldap_testbase."
     if ldap is None:
         return "You need python-ldap installed to use ldap_testbase."
     slapd = False
--- a/MoinMoin/auth/smb_mount.py	Sun Mar 01 03:49:09 2009 +0100
+++ b/MoinMoin/auth/smb_mount.py	Sun Mar 01 04:11:08 2009 +0100
@@ -6,8 +6,6 @@
     authentication at the SMB server). This can be used if you need access
     to files on some share via the wiki, but needs more code to be useful.
 
-    Note: requires Python 2.4 (for subprocess module)
-
     @copyright: 2006-2008 MoinMoin:ThomasWaldmann
                 2007 MoinMoin:JohannesBerg
     @license: GNU GPL, see COPYING for details.
--- a/MoinMoin/theme/__init__.py	Sun Mar 01 03:49:09 2009 +0100
+++ b/MoinMoin/theme/__init__.py	Sun Mar 01 04:11:08 2009 +0100
@@ -14,7 +14,7 @@
 modules = pysupport.getPackageModules(__file__)
 
 # Check whether we can emit a RSS feed.
-# RSS is broken on plain Python 2.3.x/2.4.x, and works only when installing PyXML.
+# RSS is broken on plain Python 2.4.x, and works only when installing PyXML.
 # News: A user reported that the RSS is valid when using Python 2.5.1 on Windows.
 import sys, xml
 rss_supported = sys.version_info[:3] >= (2, 5, 1) or '_xmlplus' in xml.__file__