changeset 6115:970be85fb9b9

author Thomas Waldmann <tw AT waldmann-edv DOT de>
date Tue, 20 Sep 2016 20:39:20 +0200
parents be908a22d44a
children 2e5c8fcb6bee
diffstat 1 files changed, 9 insertions(+), 45 deletions(-) [+]
line wrap: on
line diff
--- a/docs/REQUIREMENTS	Tue Sep 20 20:15:07 2016 +0200
+++ b/docs/REQUIREMENTS	Tue Sep 20 20:39:20 2016 +0200
@@ -1,29 +1,10 @@
 Python requirements
-Please use Python 2.6.x, 2.7.x, 2.5.x (in that order, first most
-recommended, last least recommended). See below about Python 2.4.
-2.7 is 2nd because it is less long tested than 2.6. If you have 2.7 by default
-then just use it, there is usually no need to get 2.6. But if you have 2.6 by
-default, just use that, because there is also no need to get 2.7.
-2.5 is last because it is OLD and not much tested any more.
+You need Python 2.7.x (older Python versions are outdated, not supported and
+not tested).
-2.4 was supported "out of the box" until (and including) moin 1.9.3.
-Since 1.9.4 the download release of moin has bundled libraries that need 2.5
-at least. Also, no moin developer still tests moin on 2.4.
-If you are willing to experiment a bit and use older libraries than the
-bundled ones, you might be able to get it working on 2.4 by replacing
-MoinMoin/support/werkzeug with werkzeug version 0.7.x and hope the best.
-Python requirements might be different for (linux or other) distribution
-packages, depending on the werkzeug version they use. Usually you do not have
-to care then, because the package maintainer already did it for you.
-You also can't use the stronger password hashes provided by passlib as it
-requires at least python 2.5 and you need to disable it in your wiki config,
-so moin does not try to use it.
-Python 3.x won't work for MoinMoin for now.
+Python 3.x won't work for MoinMoin 1.x.x.
 Python build options:
  * zlib support (required)
@@ -72,13 +53,6 @@
 jabberbot: pyxmpp SVN revision 665 or release >= 1.0.1
-Only if you are using some python < 2.5.1, you likely will need python-xml
-(pyxml) for some features. It should just work with python's standard library
-for more recent python versions. Features needing this:
- * the RSS feed (action/rss_rc)
- * GUI editor converter (converter/text_html_text_moin_wiki)
- * docbook formatter (formatter/text_docbook)
 Bundled 3rd party code
@@ -102,7 +76,7 @@
 passlib (password hashing library)
-shipped: 1.6.2
+shipped: 1.6.5
 minimum: 1.3(?)
 Note: moin could work without passlib also (NOT RECOMMENDED), but would not
@@ -119,24 +93,21 @@
 pygments (highlighting for all sorts of source code and other text files)
-shipped: 1.6
+shipped: 2.1.3
 minimum: 1.1.1 will work, maybe even older versions
 parsedatetime (parse date/time strings)
-shipped: 0.8.7
+shipped: 2.1
 minimum: 0.8.7(?)
 werkzeug (WSGI toolkit)
-shipped: 0.8.3  (note: 0.9.x requires python >= 2.6)
+shipped: 0.11.11
 minimum: 0.7.0
-Note: >= 0.6.1 will also likely work if the missing "import sys" in
- is patched.
 xappy (High-Level Python library for Xapian)
@@ -150,21 +121,14 @@
 minimum: same(?)
-Replacements for Python stdlib modules
-====================================== (fixes broken Python 2.4.3 difflib, see comment in file) ("copied from email.Header because the original is broken") (misc. brokenness up to Python 2.6, see comment in file)
 Other stuff
 =========== (taken from Amos' XML-RPC HowTo) (to be compatible with older Pythons) (not used by moin any more)
 B) MoinMoin/web/static/htdocs/applets/FCKEditor/
-shipped: 2.6.8
+shipped: 2.6.11
 required: 2.6.x