flup_frontend: __import__ compatibility fix for python 2.4
authorThomas Waldmann <tw AT waldmann-edv DOT de>
Thu, 30 Jul 2009 17:43:50 +0200
changeset 4925c37ea194d626
parent 4924 a8a777074233
child 4926 7a8e1567e7e4
flup_frontend: __import__ compatibility fix for python 2.4
MoinMoin/web/flup_frontend.py
     1.1 --- a/MoinMoin/web/flup_frontend.py	Mon Jul 27 01:55:59 2009 +0200
     1.2 +++ b/MoinMoin/web/flup_frontend.py	Thu Jul 30 17:43:50 2009 +0200
     1.3 @@ -76,7 +76,7 @@
     1.4              multi = server_type in ('threaded', 'forking')
     1.5  
     1.6              mod = self.server_types[server_type]
     1.7 -            mod = __import__(mod, fromlist=['WSGIServer'])
     1.8 +            mod = __import__(mod, globals(), locals(), ['WSGIServer'])
     1.9              WSGIServerWrapped = mod.WSGIServer
    1.10  
    1.11              class WSGIServer(WSGIServerWrapped):