changeset 137:cfbecd3400d3

make install-docs, intermap, underlay, ... imported from: moin--main--1.5--patch-139
author Thomas Waldmann <tw@waldmann-edv.de>
date Sun, 23 Oct 2005 20:36:07 +0000
parents 3fd64124fc36
children 81654a482b3a
files docs/CHANGES docs/INSTALL.html docs/UPDATE.html wiki/data/intermap.txt wiki/underlay.tar.bz2
diffstat 5 files changed, 30 insertions(+), 28 deletions(-) [+]
line wrap: on
line diff
--- a/docs/CHANGES	Sun Oct 23 19:49:35 2005 +0000
+++ b/docs/CHANGES	Sun Oct 23 20:36:07 2005 +0000
@@ -211,6 +211,8 @@
     * added IE7 (v0.9) from Dean Edwards (see http://dean.edwards.name/IE7/) -
       that should fix quite some IE bugs and annoyances (on Win32).
       * for enabling IE7, use cfg.hacks = { 'ie7': True }
+    * reducewiki now also copies all attachments (we use that to make underlay
+      directory from moinmaster wiki's data_dir)
 
   Fixes:  
     * Fixed a typo in xslt.py which led to a traceback instead of an
--- a/docs/INSTALL.html	Sun Oct 23 19:49:35 2005 +0000
+++ b/docs/INSTALL.html	Sun Oct 23 20:36:07 2005 +0000
@@ -107,7 +107,7 @@
 <h2 id="head-2fa431ad9c9bff5badd07c5ee676b19852ed28e3">Check if Python is working</h2>
 
 <p>MoinMoin needs Python to run, so the first step is to check if an usable version of Python is installed and correctly set-up. If this is not the case, you will have to fix that before you can proceed. </p>
-<p>The <tt>CHANGES</tt> file in the MoinMoin archive mentions what versions are supported. Python 2.2.2 is the minimum requirement for MoinMoin 1.3, but we suggest you use the latest Python 2.3.x version because Python 2.2.x has annoying known bugs. You can use Python 2.4.x if you want, it works well too. </p>
+<p>The <tt>CHANGES</tt> file in the MoinMoin archive mentions what versions are supported. Python 2.3 is the minimum requirement for MoinMoin 1.5, but we suggest you use the latest Python release version. </p>
 <p>You can download Python at <a class="external" href="http://www.python.org/download/"><img src="wiki/htdocs/modern/img/moin-www.png" alt="[WWW]" height="11" width="11"> http://www.python.org/download/</a>. </p>
 <p>If you are pretty sure an acceptable version of Python is installed but the commands below do not work, this may be because your Python files are not in the <em>search path</em>. Correctly setting the search path is outside the scope of this document; please ask for help on your favorite Python, Linux, or Windows discussion board. </p>
 <p>If you have shell access, checking if Python is working is very simple. Just type the following command, and look at the result: 
@@ -127,10 +127,6 @@
 echo "CGI scripts work"
 echo "Now we try to invoke Python interpreters and get their versions:"
 python -V 2&gt;&amp;1
-python2 -V 2&gt;&amp;1
-python2.0 -V 2&gt;&amp;1
-python2.1 -V 2&gt;&amp;1
-python2.2 -V 2&gt;&amp;1
 python2.3 -V 2&gt;&amp;1
 python2.4 -V 2&gt;&amp;1
 echo "Finished."
@@ -140,7 +136,7 @@
 
 <h2 id="head-119b1acf8110bb618e4f366c3d1f8a35ad625f75">Download MoinMoin</h2>
 
-<p>To download the distribution archive, go to the <a class="external" href="http://sourceforge.net/project/showfiles.php?group_id=8482"><img src="wiki/htdocs/modern/img/moin-www.png" alt="[WWW]" height="11" width="11"> download area</a> and fetch the lastest archive. </p>
+<p>To download the distribution archive, go to the <a class="external" href="http://sourceforge.net/project/showfiles.php?group_id=8482"><img src="wiki/htdocs/modern/img/moin-www.png" alt="[WWW]" height="11" width="11"> download area</a> and fetch the latest archive. </p>
 <p>The next step is to unpack the distribution archive (which you have done already if you are reading this text from your hard drive). If you read this on the web, the distribution comes in a versioned <tt>.tar.gz</tt> archive, which you can unpack as shown below. </p>
 <ul>
 <li><p> On Windows </p>
@@ -160,12 +156,12 @@
 </ul>
 </li>
 </ul>
-<p>The distribution archive will always unpack into a directory named <tt>moin-&lt;version&gt;</tt>, for example <tt>moin-1.3</tt>. </p>
+<p>The distribution archive will always unpack into a directory named <tt>moin-&lt;version&gt;</tt>, for example <tt>moin-1.5</tt>. </p>
 <p>Here is how you would unpack the archive (using GNU tar) and enter the directory with the MoinMoin files: 
 </p>
 <pre>
-&gt; tar xzf moin-1.3.1.tar.gz
-&gt; cd moin-1.3.1
+&gt; tar xzf moin-1.5.0.tar.gz
+&gt; cd moin-1.5.0
 </pre>
 
 <h2 id="head-a84e58c8b4256bd645b9c47b5a900219a356259f">Install MoinMoin</h2>
@@ -886,6 +882,12 @@
 data_dir = '/var/www/moin/mywiki/data/'
 data_underlay_dir = '/var/www/moin/mywiki/underlay/'
 </pre>
+<p>If you do not want to use absolute paths, you can use Python's os module to construct the relative paths: </p>
+<pre>
+import os 
+data_dir = os.path.join(os.path.dirname(__file__), 'data/')
+data_underlay_dir = os.path.join(os.path.dirname(__file__), 'underlay/')
+</pre>
 <p>Test that the wiki works after this change. </p>
 <ul>
 <li style="list-style-type:none"><p><img src="wiki/htdocs/modern/img/idea.png" alt="(!)" height="15" width="15"> In 1.2 and earlyer, the configuration file is called <tt>moin_config.py</tt>. </p>
@@ -894,7 +896,7 @@
 
 <h3 id="head-b628477f88ab294636a22af4ee665656a8897b3a">Changes to Apache `httpd.conf`</h3>
 
-<p>After you wiki is running as cgi script, conver it to run with mod_python.  </p>
+<p>After your wiki is running as cgi script, convert it to run with mod_python.  </p>
 <p>If you run your wiki as cgi as we recommended before, remove or comment the <a class="nonexistent" href="http://moinmaster.wikiwikiweb.de/ScriptAlias">ScriptAlias</a> directive: 
 </p>
 <pre>
@@ -910,7 +912,7 @@
     PythonHandler MoinMoin.request::RequestModPy.run
 &lt;/Location&gt;
 </pre>
-<p>If you have multiple <a href="http://moinmaster.wikiwikiweb.de/MoinMoin">MoinMoin</a> instances then add one location directive for each one (changing the paths as appropriate). </p>
+<p>If you have multiple <a href="http://moinmaster.wikiwikiweb.de/MoinMoin">MoinMoin</a> instances then add one location directive for each one (changing the paths as appropriate) and add a line with the directive <tt>PythonInterpreter&nbsp;mywiki</tt> to each Location section. With this directive different subinterpreters with completely separate namespaces will be used for each wiki (see <a class="external" href="http://modpython.org/live/current/doc-html/pyapi-interps.html"><img src="wiki/htdocs/modern/img/moin-www.png" alt="[WWW]" height="11" width="11"> here</a> for details). </p>
 <p>If you did not install <a href="http://moinmaster.wikiwikiweb.de/MoinMoin">MoinMoin</a> in the default location, you will have to add the path to <a href="http://moinmaster.wikiwikiweb.de/MoinMoin">MoinMoin</a> to the system path: 
 </p>
 <pre>
@@ -1684,7 +1686,7 @@
 </tr>
 </table>
 </div>
-<p>This installation procedure was tested with Apache 1.3.26 and Apache 2.0.44 for Windows running on Windows ME, and using Python 2.2.2 and 2.3. </p>
+<p>This installation procedure was tested with Apache 1.3.26 and Apache 2.0.44 for Windows running on Windows ME, and using Python 2.3. </p>
 
 <h3 id="head-18c7f9f6c7f20cad8a2598f80aba6a6b36bae585">Preparation</h3>
 
@@ -1714,7 +1716,7 @@
 
 <p>There are currently two different distributions of Python available for Windows. The normal Python distribution is available from <a href="http://www.python.org"><img src="wiki/htdocs/modern/img/moin-www.png" alt="[WWW]" height="11" width="11"> http://www.python.org</a>. This is distributed as a windows executable (.exe) file. </p>
 <p>An alternative distribution called <strong>ActivePython</strong> is available from <a href="http://www.activestate.com/"><img src="wiki/htdocs/modern/img/moin-www.png" alt="[WWW]" height="11" width="11"> http://www.activestate.com/</a>. This distribution uses the MSI Installer and contains some tools specific to the Windows operating system and a popular Windows IDE called Pythonwin.  ActivePython is available for free; an email address is requested (but not required) before downloading. </p>
-<p>MoinMoin will work with either distribution, but requires Python release 2.2.2 or later.  Download and install the distribution of your choice.  Questions and problems dealing with the Python installation process should be resolved through the use of resources provided by Python.org or ActiveState.  Be sure your Python installation is correct before proceeding. </p>
+<p>MoinMoin will work with either distribution, but requires Python release 2.3 or later.  Download and install the distribution of your choice.  Questions and problems dealing with the Python installation process should be resolved through the use of resources provided by Python.org or ActiveState.  Be sure your Python installation is correct before proceeding. </p>
 
 <h3 id="head-c76f9a659995f587c02878baf3877ab5bd08a5bd">Installing MoinMoin</h3>
 
@@ -1727,7 +1729,7 @@
 cd \TEMP\moin-x.x
 C:\Python\python setup.py install --record=install.log
 </pre>
-<p>The above commands will add MoinMoin to your <tt>C:\Python</tt> installation and create an <tt>install.log</tt> file in <tt>C:\temp\moin-x.x</tt> listing all the copied files. You may use Windows Explorer to examine the newly created folders within <tt>C:\Python</tt>. You should find a <tt>C:\Python\share\moin</tt> folder. With Python 2.2 and later you will also find a <tt>C:\Python\Lib\site-packages\MoinMoin</tt> folder. The <tt>MoinMoin</tt> folder contains many Python scripts and several subfolders. </p>
+<p>The above commands will add MoinMoin to your <tt>C:\Python</tt> installation and create an <tt>install.log</tt> file in <tt>C:\temp\moin-x.x</tt> listing all the copied files. You may use Windows Explorer to examine the newly created folders within <tt>C:\Python</tt>. You should find a <tt>C:\Python\share\moin</tt> folder. With Python 2.3 and later you will also find a <tt>C:\Python\Lib\site-packages\MoinMoin</tt> folder. The <tt>MoinMoin</tt> folder contains many Python scripts and several subfolders. </p>
 <p>You are now ready to create a wiki instance. </p>
 
 <h3 id="head-ba9ed0d8dd27b7bc62472aa0d24e8102dd103deb">Creating a Wiki Instance</h3>
@@ -1896,7 +1898,7 @@
 
 <h3 id="head-060b14babb0736cc50274d972342cb03248902b9">Requirements</h3>
 
-<p>Before you install <a class="interwiki" title="MoinMoin" href="http://moinmoin.wikiwikiweb.de/MoinMoin"><img src="wiki/htdocs/modern/img/moin-inter.png" alt="[MoinMoin]" height="16" width="16">MoinMoin</a>, make sure you have the necessary infra-structure in place, namely the <em>Internet Information Services</em> webserver (any version should be OK), and a <em>Python</em> installation (version 2.2.2 is required, 2.3 or higher is recommended). </p>
+<p>Before you install <a class="interwiki" title="MoinMoin" href="http://moinmoin.wikiwikiweb.de/MoinMoin"><img src="wiki/htdocs/modern/img/moin-inter.png" alt="[MoinMoin]" height="16" width="16">MoinMoin</a>, make sure you have the necessary infra-structure in place, namely the <em>Internet Information Services</em> webserver (any version should be OK), and a <em>Python</em> installation (version 2.3 is required, the latest python release is recommended). </p>
 <p>In the following description, we assume that you have installed or will install things to these locations: </p>
 <ul>
 <li><p> IIS to its default location </p>
@@ -2135,10 +2137,6 @@
 echo "CGI scripts work"
 echo "Now we try to invoke Python interpreters and get their versions:"
 python -V 2&gt;&amp;1
-python2 -V 2&gt;&amp;1
-python2.0 -V 2&gt;&amp;1
-python2.1 -V 2&gt;&amp;1
-python2.2 -V 2&gt;&amp;1
 python2.3 -V 2&gt;&amp;1
 python2.4 -V 2&gt;&amp;1
 echo "Finished."
--- a/docs/UPDATE.html	Sun Oct 23 19:49:35 2005 +0000
+++ b/docs/UPDATE.html	Sun Oct 23 20:36:07 2005 +0000
@@ -269,11 +269,11 @@
 
 <h4 id="head-64b74b335c0bb5764150db10b4f12dc7b9b1154f">Deprecation Note</h4>
 
-<p>This page is deprecated (at least the version specific stuff on it), for 1.4 it will be gone and we will use CHANGES file exclusively. </p>
+<p>This page is deprecated (at least the version specific stuff on it), for 1.5 it will be gone and we will use CHANGES file exclusively. </p>
 <a id="bottom"></a>
 
 </div>
-<p id="pageinfo" class="info" lang="en" dir="ltr">last edited 2005-02-02 20:39:41 by <span title="p5082DDED.dip0.t-ipconnect.de">AlexanderSchremmer</span></p>
+<p id="pageinfo" class="info" lang="en" dir="ltr">last edited 2005-09-22 19:01:19 by <span title="p54A22AB0.dip0.t-ipconnect.de">ThomasWaldmann-1078021017.39.37203</span></p>
 <div id="pagebottom"></div>
 </div>
 </body>
--- a/wiki/data/intermap.txt	Sun Oct 23 19:49:35 2005 +0000
+++ b/wiki/data/intermap.txt	Sun Oct 23 20:36:07 2005 +0000
@@ -17,7 +17,6 @@
 Thinki http://www.thinkware.se/cgi-bin/thinki.cgi/
 PythonFaq http://www.python.org/cgi-bin/faqw.py?req=show&file=faq$PAGE.htp
 DocBook http://docbook.org/wiki/moin.cgi/
-AwarenessWiki http://aware.wiki.taoriver.net/moin.cgi/
 SpackOrg http://www.spack.org/index.cgi/
 ESW http://esw.w3.org/topic/
 OSPedia http://ospedia.osdir.com/
@@ -36,32 +35,35 @@
 CPAN http://search.cpan.org/perldoc?
 NemWiki http://nematologists.org.au/nemwiki
 PostWiki http://www.postwiki.net/
+GentooLinux http://gentoo-wiki.com/
+CoLinux http://wiki.colinux.org/cgi-bin/
+LinuxMM http://linux-mm.org/
+LinuxNet http://linux-net.osdl.org/index.php/
+KernelNewbies http://wiki.kernelnewbies.org/
+Spamikaze http://spamikaze.org/
 
 ## Updated 2004-11-19 from http://www.usemod.com/cgi-bin/mb.pl?InterMapTxt
 ## Please modify the upper part of this page only
 
 AbbeNormal http://ourpla.net/cgi/pikie?
-AcadWiki http://xarch.tu-graz.ac.at/autocad/wiki/
 Acronym http://www.acronymfinder.com/af-query.asp?String=exact&Acronym=
 Advogato http://www.advogato.org/
-ALife http://news.alife.org/wiki/index.php?
 AnnotationWiki http://www.seedwiki.com/page.cfm?wikiid=368&doc=
 AtomWiki http://intertwingly.net/wiki/pie/
 BitTorrentFAQ http://www.bamber.org/wiki/ow.asp?
 BookShelved http://bookshelved.org/cgi-bin/wiki.pl?
-BuildingControlsWiki http://www.buildingcontrols.de/
+BuildingControlsWiki http://wiki.buildingcontrols.de/CoMa.php?CoMa=
 C2find http://c2.com/cgi/wiki?FindPage&value=
 Cache http://www.google.com/search?q=cache:
 CarpeWiki http://carpe.com/wiki/wiki.pl?
 CommunityWiki http://www.emacswiki.org/cgi-bin/community?
-ConcurrenceWiki http://concurrence.sourceforge.net/cgi-bin/moin.cgi/
 CraoWiki http://wiki.crao.net/index.php/
 CreationMatters http://www.ourpla.net/cgi-bin/wiki.pl?
 DebianforumDeWiki http://www.debianforum.de/wiki/?page=
 Dictionary http://www.dict.org/bin/Dict?Database=*&Form=Dict1&Strategy=*&Query=
 Disinfopedia http://www.disinfopedia.org/wiki.phtml?title=
 DseWiki http://www.wikiservice.at/dse/wiki.cgi?
-EmacsWiki http://www.emacswiki.org/cgi-bin/wiki/
+EmacsWiki http://www.emacswiki.org/
 Foldoc http://www.foldoc.org/foldoc/foldoc.cgi?
 FoxWiki http://fox.wikis.com/wc.dll?Wiki~
 FractalWiki http://www.wikiservice.at/fractal/wikidev.cgi?
@@ -83,7 +85,7 @@
 MetaWiki http://sunir.org/apps/meta.pl?
 MetaWikiPedia http://meta.wikipedia.org/wiki/
 MoinMoin http://moinmoin.wikiwikiweb.de/
-OddMuse http://www.emacswiki.org/cgi-bin/oddmuse/
+OddMuse http://www.oddmuse.org/
 OPAG http://opag.ca/wiki?
 OpenMind http://www2.iro.umontreal.ca/~paquetse/cgi-bin/om.cgi?
 OpenWiki http://openwiki.com/?
Binary file wiki/underlay.tar.bz2 has changed