diff MoinMoin/apps/admin/views.py @ 266:7a6b116afa20

upgrade to flask 0.7.1 (not compatible to older flasks) to upgrade to flask 0.7.1 you need to activate your virtual env and run: pip install --upgrade flask what I had to do for upgrading moin src to flask 0.7.1: ran the flask upgrade script, review what it did added template_folder='templates' to BluePrint initializers where needed moved templates to a subdirectory having the shortname of the BluePrint require flask >=0.7.1 in setup.py
author Thomas Waldmann <tw AT waldmann-edv DOT de>
date Sat, 02 Jul 2011 20:18:34 +0200
parents 5dd1db45ed55
children 43f5e5aa061a
line wrap: on
line diff
--- a/MoinMoin/apps/admin/views.py	Tue Jun 28 19:45:17 2011 +0200
+++ b/MoinMoin/apps/admin/views.py	Sat Jul 02 20:18:34 2011 +0200
@@ -83,7 +83,7 @@
             flash('%s.%s: %s -> %s' % (user_name, key, unicode(oldval), unicode(val), ), "info")
         else:
             flash('modifying %s.%s failed' % (user_name, key, ), "error")
-    return redirect(url_for('admin.userbrowser'))
+    return redirect(url_for('.userbrowser'))
 
 
 @admin.route('/mail_recovery_token', methods=['GET', 'POST', ])
@@ -92,7 +92,7 @@
     Send user an email so he can reset his password.
     """
     flash("mail recovery token not implemented yet")
-    return redirect(url_for('admin.userbrowser'))
+    return redirect(url_for('.userbrowser'))
 
 
 @admin.route('/sysitems_upgrade', methods=['GET', 'POST', ])
@@ -113,7 +113,7 @@
             flash(_('System items upgrade failed due to the following error: %(error)s.', error=e), 'error')
         else:
             flash(_('System items have been upgraded successfully!'))
-        return redirect(url_for('admin.index'))
+        return redirect(url_for('.index'))
 
 
 from MoinMoin.config import default as defaultconfig