view docs/admin/requirements.rst @ 2109:38b5c2746f83

raise minimum requirement to python 2.7 now that debian wheezy is stable (and thus even debian stable has python 2.7 - almost 3 years after the python 2.7 release), it is time to move on. there are some nice features in 2.7 - we can use them now: there is also no risk any more that language or library features creep in unnoticed that are incompatible with the minimum requirement. we also save some time as we don't have to test on / care for 2.6 any more. about this changeset: most should be self-explanatory, except this: MoinMoin/constants/ - we could not use unicode key constants yet due to a bug in pre-2.6.5 python that did not allow unicode keys in kwargs. The change in MoinMoin/storage/middleware/ is also related to that, we just had to make sure keys are str, not unicode as that dict later was exploded into a function call like f(**doc). notes for developers: if you developed on 2.6 until now, you need to create a fresh new virtualenv using python 2.7.
author Thomas Waldmann <tw AT waldmann-edv DOT de>
date Sat, 04 May 2013 16:08:33 +0200
parents 47ed1aa1f741
children 42d4f773ca4a
line wrap: on
line source

MoinMoin requires Python 2.7.x.
We usually test using CPython and this is what we recommend.

You can also try PyPy, it seems to work.


For moin, you can use any server compatible with WSGI:

* the builtin "moin" server is recommended for desktop wikis, testing,
  debugging, development, adhoc-wikis, etc.
* apache with mod_wsgi is recommended for bigger/busier wikis.
* other WSGI-compatible servers or middlewares are usable
* For cgi, fastcgi, scgi, ajp, etc., you can use the "flup" middleware:
* IIS with ISAPI-WSGI gateway is also compatible:


For dependency information, please see

If you use easy_install or pip or our ``quickinstall`` script, then
dependencies are usually automatically dealt with.

On the client side, you need:

* a decent web browser that supports W3C standards HTML 5 and CSS 2.1 as well
  as JavaScript:

  - any current version of Firefox, Chrome, Opera, Safari, Internet Explorer
    (IE9 or IE10) should work.
  - usage of older Internet Explorer versions is not recommended and not
    supported because they are known for causing issues.
    For Windows 7 (or 8) Microsoft provides IE9 or IE10.
* Java browser plugin (optional, needed if you want to use TWikiDraw or
  AnyWikiDraw drawing applets).