log setup.py @ 2941:ccad02fc9281

age author description
Wed, 10 Jun 2015 01:23:47 +0200 Thomas Waldmann use emeraldtree 0.10.0 release
Sat, 21 Feb 2015 08:15:07 -0700 RogerHaase fix E402 errors; imports not at top of file after installing pep8 1.6.1; partial fix for #492
Thu, 12 Feb 2015 22:08:56 -0700 RogerHaase workaround for #491 Werkzeug 0.10.1 breaks item links for +modify, +history...
Tue, 06 Jan 2015 13:36:04 -0700 RogerHaase fix #474 python setup.py extract_messages - omits /themes/basic/templates/*.html files
Fri, 17 Oct 2014 06:14:37 -0700 RogerHaase fix #443 upgrade font-awesome to 4.1; run m quickinstall to install renamed fonts
Sat, 02 Aug 2014 21:13:03 +0200 Thomas Waldmann merged
Sat, 02 Aug 2014 21:08:11 +0200 Thomas Waldmann upgrade tests to py.test 2.5/2.6, thanks to dimazest!
Tue, 29 Jul 2014 22:17:58 +0200 Thomas Waldmann fix jQuery-File-Upload version at 4.4.2 as newer one is not yet tested
Thu, 03 Jul 2014 22:04:50 +0200 Thomas Waldmann merged
Wed, 25 Jun 2014 22:20:52 +0530 Ajitesh Gupta Added pygments css classes in basic theme by installing pygments Xstatic package in the virtual environment and importing css files from there. Also removed the manually added pygments definitions in the foobar and modernized themes and imported pygments css in the same wasy as done in the basic theme.
Mon, 30 Jun 2014 15:13:54 -0700 RogerHaase #443 workaround, xstatic font-awesome 4.1.0.1 upgrade breaks icons, revert to 3.2.1.1
Fri, 20 Jun 2014 15:52:42 +0530 Saurabh Kathpalia Added XStatic.JQuery.TableSorter plugin in +tickets view
Fri, 09 May 2014 15:30:04 -0700 RogerHaase fix #429 by setting flask-script to 1.0.0
Wed, 02 Apr 2014 14:55:54 -0700 RogerHaase fix new pep8 errors generated after pep8 is upgraded to 1.5.1
Mon, 31 Mar 2014 11:47:09 -0700 RogerHaase remove PIL, use Pillow as successor (PIL has not been updated for almost 5 years)
Sat, 22 Mar 2014 11:47:43 -0700 RogerHaase upgrade to xstatic-bootstrap 3.1.1.2; recompiling basic.less creates many changes to basic.css, but no new breakage
Mon, 10 Mar 2014 19:57:51 +0100 Thomas Waldmann setup.py: fix indentation, add comment about flatland
Mon, 10 Mar 2014 21:50:28 +0530 Punit Mittal Changed installation link of flatland
Sun, 02 Feb 2014 17:14:23 +0100 Thomas Waldmann merged bootstrap and main repo
Wed, 21 Aug 2013 19:33:24 +0530 sharky93 Merged thomaswaldmann/moin-2.0 into default
Wed, 21 Aug 2013 19:32:38 +0530 sharky93 bootstrap version bump, moved the bootstrap js include from snipetts to base.html
Wed, 07 Aug 2013 19:38:08 +0530 sharky93 textarea auto-resize plugin added as an xstatic package
Wed, 07 Aug 2013 02:50:06 +0530 sharky93 Uses the xstatic-font-awesome package, fixes icon-stacking for the local panel
Sat, 16 Nov 2013 14:32:15 -0700 RogerHaase workaround for #385 RunTimeError: working outside of application context (pdfminer == 20131113)
Thu, 14 Nov 2013 13:04:23 -0700 RogerHaase fix #379 quickinstall.py fails with obscure error message
Wed, 02 Oct 2013 15:22:08 -0700 RogerHaase reduce support for ie7 and ie8; ie7 cannot save user settings, ie8 cannot view svg images, close #265
Wed, 02 Oct 2013 09:56:39 -0700 RogerHaase pip 1.4 implements PEP 426 version metadata, packages with non-standard version numbers are not found: #377, https://github.com/euske/pdfminer/issues/27
Tue, 20 Aug 2013 22:07:23 +0200 Thomas Waldmann upgrade to bootstrap v3, add font-awesome
Sat, 03 Aug 2013 15:43:53 +0200 Thomas Waldmann setup.py: get whoosh from pypi, require bootstrap 2.3, test fixes needed for latest versions of our dependencies
Sun, 07 Jul 2013 10:59:31 +0200 Thomas Waldmann require xstatic-bootstrap package with twitter bootstrap
Sat, 15 Jun 2013 02:29:07 +0200 Thomas Waldmann Raise requirements to require latest flask/werkzeug/jinja2 release, latest emeraldtree.
Sat, 04 May 2013 16:08:33 +0200 Thomas Waldmann raise minimum requirement to python 2.7
Sun, 31 Mar 2013 17:29:18 +0200 Thomas Waldmann docs / setup.py: mention pillow as an alternative to PIL
Wed, 20 Mar 2013 01:25:01 +0100 Thomas Waldmann merged default branch into gae branch gae
Tue, 19 Mar 2013 21:16:07 +0100 Thomas Waldmann switch to whoosh 2.5
Mon, 18 Feb 2013 00:46:53 +0100 Thomas Waldmann fix lots of pep8 issues, mainly E12x
Mon, 11 Feb 2013 04:49:04 +0100 Thomas Waldmann lots of pep8 fixes
Sat, 09 Feb 2013 19:38:31 +0100 Thomas Waldmann merged default branch into gae branch gae
Sun, 20 Jan 2013 16:12:13 +0100 Thomas Waldmann passlib support - strong crypto hashes
Sun, 23 Dec 2012 19:34:19 +0100 Thomas Waldmann require emeraldtree 0.9.2, fixes #192
Fri, 14 Dec 2012 01:11:00 +0100 Thomas Waldmann temporary workaround for issue #293 (likely some import magic incompatibility between gae dev_appserver and flask) gae
Sat, 01 Dec 2012 15:00:46 +0100 Thomas Waldmann merged default into gae branch gae
Thu, 15 Nov 2012 22:17:02 +0100 Reimar Bauer setup: require pytest-pep8<1.0.3 because pytest-pep8 1.0.3 requires pytest 2.3 and our test code needs to be refactored for pytest 2.3
Thu, 15 Nov 2012 21:28:28 +0100 Reimar Bauer setup: new version of XStatic-svg-edit-moin, fixes #149 by the patch of Sam Toyer in the save extension
Tue, 30 Oct 2012 23:50:24 +0100 Thomas Waldmann require pytest < 2.3, because pytest 2.3.x doesn't work with our test code, likely due to the fixture changes done after 2.2
Thu, 27 Sep 2012 13:46:13 -0700 Roger Haase CSS and javascript changes to support obsolete IE7 and IE8 browsers,
Sun, 23 Sep 2012 16:18:07 +0200 Thomas Waldmann setup.py: we need whoosh 2.5 from default branch for GAE gae
Mon, 13 Aug 2012 00:34:15 +0200 Thomas Waldmann add markdown converter, thanks to Andreas Kloeckner
Sun, 15 Jul 2012 23:31:54 +0200 Thomas Waldmann fix message extraction configuration in setup.py
Sun, 15 Jul 2012 23:23:18 +0200 Thomas Waldmann implement i18n for .js by using jinja2 js templates
Sun, 15 Jul 2012 17:51:57 +0200 Thomas Waldmann merged
Thu, 28 Jun 2012 13:16:15 -0700 Roger Haase remove multiDownload jquery plugin
Sun, 08 Jul 2012 14:24:32 +0200 Thomas Waldmann implemented mongodb store, add pymongo to setup.py
Sun, 24 Jun 2012 16:14:45 +0200 Thomas Waldmann make file ends pep8 compliant (== exactly 1 LF at EOF)
Sun, 24 Jun 2012 14:23:46 +0200 Thomas Waldmann fix some pep8 issues, remove the fixed files from pep8 checker's exlusion list
Sun, 24 Jun 2012 14:13:01 +0200 Thomas Waldmann remove test_sourcecode, replace it by pytest-pep8
Sun, 10 Jun 2012 18:26:07 +0200 Thomas Waldmann require pep8 in setup.py, import pep8 from sys.path (not from .)
Sun, 20 May 2012 03:59:08 +0200 Thomas Waldmann use polyglot writer, require emeraldtree >= 0.9.1
Sun, 13 May 2012 20:12:48 +0200 Thomas Waldmann setup.py: add missing import, use 2.4x branch of whoosh repo to get latest maintenance updates
Tue, 24 Apr 2012 22:17:36 +0200 Thomas Waldmann setup.py: make sure it uses whoosh repo tip from our repo