changeset 2619:2232ac23264b

update docs about required stylus version and installing node
author Thomas Waldmann <tw AT waldmann-edv DOT de>
date Sun, 08 Jun 2014 00:10:00 +0200
parents a8bf7c1d94fb
children b6437eb6e332
files docs/devel/development.rst
diffstat 1 files changed, 6 insertions(+), 1 deletions(-) [+]
line wrap: on
line diff
--- a/docs/devel/development.rst	Sat Jun 07 23:30:02 2014 +0200
+++ b/docs/devel/development.rst	Sun Jun 08 00:10:00 2014 +0200
@@ -86,9 +86,14 @@
      ./m tests  # Windows: m tests
 
 * install NodeJS and NPM with Linux package manager; Windows users may download both from http://nodejs.org/download/
+
+  * On Ubuntu 14.04 you need to install "npm" and "nodejs-legacy" (to get the "node" command).
+
 * install stylus::
 
-    sudo npm install stylus -g  # Windows: npm install stylus -g
+    sudo npm install stylus@0.42.2 -g  # Windows: npm install stylus@0.42.2 -g
+    # we need 0.42.2 because with more recent versions, --compress compresses
+    # complete output to 1 line (0.42.2 compresses to 1 line per rule)
     stylus -V  # show version number to prove it works
 * install lessc ("less" below is not a typo)::