changeset 2207:96abee43bb39

pip 1.4 implements PEP 426 version metadata, packages with non-standard version numbers are not found: #377, https://github.com/euske/pdfminer/issues/27
author RogerHaase
date Wed, 02 Oct 2013 09:56:39 -0700
parents e58f8d21b373
children 0aee7913a866
files setup.py
diffstat 1 files changed, 2 insertions(+), 2 deletions(-) [+]
line wrap: on
line diff
--- a/setup.py	Sun Sep 15 14:02:19 2013 +0200
+++ b/setup.py	Wed Oct 02 09:56:39 2013 -0700
@@ -103,7 +103,7 @@
                               # note: pytest-pep8 1.0.3 needs pytest 2.3
         'whoosh>=2.5.0',  # needed for indexed search
         'sphinx>=1.1',  # needed to build the docs
-        'pdfminer',  # pdf -> text/plain conversion
+        'pdfminer>=20110515',  # pdf -> text/plain conversion
         'passlib>=1.6.0',  # strong password hashing (1.6 needed for consteq)
         'XStatic>=0.0.2',  # support for static file pypi packages
         'XStatic-Bootstrap>=3.0.0.1',
@@ -111,7 +111,7 @@
         'XStatic-CKEditor>=3.6.1.2',
         'XStatic-jQuery>=1.8.2',
         'XStatic-jQuery-File-Upload>=4.4.2',
-        'XStatic-JSON-js',
+        'XStatic-JSON-js>=0.0.0.40f3377a63.1',
         'XStatic-svgweb>=2011.2.3.2',
         'XStatic-TWikiDraw-moin>=2004.10.23.2',
         'XStatic-AnyWikiDraw>=0.14.2',