changeset 1371:a95b42da91f6

require pep8 in setup.py, import pep8 from sys.path (not from .)
author Thomas Waldmann <tw AT waldmann-edv DOT de>
date Sun, 10 Jun 2012 18:26:07 +0200
parents cd42e6133f5f
children dd9450af63ae
files MoinMoin/_tests/test_sourcecode.py setup.py
diffstat 2 files changed, 2 insertions(+), 1 deletions(-) [+]
line wrap: on
line diff
--- a/MoinMoin/_tests/test_sourcecode.py	Sun Jun 10 18:21:53 2012 +0200
+++ b/MoinMoin/_tests/test_sourcecode.py	Sun Jun 10 18:26:07 2012 +0200
@@ -11,7 +11,7 @@
 
 import re, time
 import pytest
-from . import pep8
+import pep8
 
 import py
 
--- a/setup.py	Sun Jun 10 18:21:53 2012 +0200
+++ b/setup.py	Sun Jun 10 18:26:07 2012 +0200
@@ -93,6 +93,7 @@
         'pygments>=1.4', # src code / text file highlighting
         'Werkzeug>=0.8.1', # wsgi toolkit
         'pytest>=2.1', # pytest is needed by unit tests
+        'pep8', # pep8 style checker is needed by unit tests
         'whoosh>=2.4.0', # needed for indexed search
         'sphinx>=1.1', # needed to build the docs
         'pdfminer', # pdf -> text/plain conversion