changeset 1842:b02d552029c8

require pytest < 2.3, because pytest 2.3.x doesn't work with our test code, likely due to the fixture changes done after 2.2
author Thomas Waldmann <tw AT waldmann-edv DOT de>
date Tue, 30 Oct 2012 23:50:24 +0100
parents 7a07ddddb256
children 1ac84f17c5c1 920de041c03f
files setup.py
diffstat 1 files changed, 3 insertions(+), 1 deletions(-) [+]
line wrap: on
line diff
--- a/setup.py	Tue Oct 30 23:41:47 2012 +0100
+++ b/setup.py	Tue Oct 30 23:50:24 2012 +0100
@@ -93,7 +93,9 @@
         'Jinja2>=2.6', # template engine
         'pygments>=1.4', # src code / text file highlighting
         'Werkzeug>=0.8.1', # wsgi toolkit
-        'pytest>=2.1', # pytest is needed by unit tests
+        'pytest>=2.1, <2.3', # pytest is needed by unit tests
+                             # note: currently 2.3.x is not compatible with our test code,
+                             # likely due to the fixtures changes.
         'pytest-pep8', # coding style checker
         'whoosh>=2.4.0', # needed for indexed search
         'sphinx>=1.1', # needed to build the docs