changeset 1861:b85f46013e3a

setup: require pytest-pep8<1.0.3 because pytest-pep8 1.0.3 requires pytest 2.3 and our test code needs to be refactored for pytest 2.3
author Reimar Bauer <rb.proj AT googlemail DOT com>
date Thu, 15 Nov 2012 22:17:02 +0100
parents dab0253193eb
children afa63a0cc1e1
files setup.py
diffstat 1 files changed, 2 insertions(+), 1 deletions(-) [+]
line wrap: on
line diff
--- a/setup.py	Thu Nov 15 21:28:28 2012 +0100
+++ b/setup.py	Thu Nov 15 22:17:02 2012 +0100
@@ -96,7 +96,8 @@
         'pytest>=2.1, <2.3', # pytest is needed by unit tests
                              # note: currently 2.3.x is not compatible with our test code,
                              # likely due to the fixtures changes.
-        'pytest-pep8', # coding style checker
+        'pytest-pep8<1.0.3', # coding style checker
+                             # note: pytest-pep8 1.0.3 needs pytest 2.3
         'whoosh>=2.4.0', # needed for indexed search
         'sphinx>=1.1', # needed to build the docs
         'pdfminer', # pdf -> text/plain conversion