changeset 449:dfa71b20022c

requirements: add a note that pypy >= 1.6 works ok now
author Thomas Waldmann <tw AT waldmann-edv DOT de>
date Sat, 20 Aug 2011 13:00:55 +0200
parents 3d3230f84e5f
children ad338b37458c 9e4f94558847 8ae3786e50bf
files docs/admin/requirements.rst
diffstat 1 files changed, 3 insertions(+), 6 deletions(-) [+]
line wrap: on
line diff
--- a/docs/admin/requirements.rst	Thu Aug 18 18:02:51 2011 +0200
+++ b/docs/admin/requirements.rst	Sat Aug 20 13:00:55 2011 +0200
@@ -3,13 +3,10 @@
 ============
 
 MoinMoin requires Python >= 2.6 and < 3.0.
-
-Python build options (in case you have to build your own Python):
+We usually test using CPython and this is what we recommend.
 
-* zlib support (required)
-* ucs4 (32bit unicode, recommended)
-* ucs2 also works for most users (not recommended)
-
+You can also try PyPy - PyPy >= 1.6 seems to work OK with moin.
+Hint: modify the quickinstall script so it uses PYTHON=pypy.
 
 Servers
 =======