changeset 382:f0b716541202

action.arnica_slides: ensureversion not used parameter request removed
author Reimar Bauer <rb.proj AT googlemail DOT com>
date Sat, 09 May 2009 17:08:17 +0200
parents 7e2f4d3c1007
children 710954cd1706
files data/plugin/action/arnica_slides.py
diffstat 1 files changed, 5 insertions(+), 5 deletions(-) [+]
line wrap: on
line diff
--- a/data/plugin/action/arnica_slides.py	Thu May 07 23:42:43 2009 +0200
+++ b/data/plugin/action/arnica_slides.py	Sat May 09 17:08:17 2009 +0200
@@ -27,7 +27,7 @@
 
 action_name = __name__.split('.')[-1]
 
-def ensureversion(request, version):
+def ensureversion(version):
     """ Ensures that the version of MoinMoin is greater or equal than
     version. 
      
@@ -348,7 +348,7 @@
         request = self.request
         if not request.user.may.read(pagename):
             return _("You are not allowed to view this page!"), "error"
-        if not ensureversion(request, '1.9.0'):
+        if not ensureversion('1.9.0'):
             target = request.form.get('target', [''])[0]
             images = request.form.get('images', [''])[0]
             original_images = request.form.get('original_images', [''])[0]
@@ -388,7 +388,7 @@
         web['src'] = cache.url(request, target)
         web['title'] = target
 
-        if not ensureversion(request, '1.9.0'):
+        if not ensureversion('1.9.0'):
             mimetype = "text/html"
             request.emit_http_headers(["Content-Type: %s; charset=%s" % (mimetype, config.charset)])
 
@@ -410,7 +410,7 @@
         _ = self.request.getText
 
         request = self.request
-        if not ensureversion(request, '1.9.0'):
+        if not ensureversion('1.9.0'):
             pagename = request.form.get('pagename', [self.pagename])[0]
             command = request.form.get('do', ['none'])[0]
             target = request.form.get('target', [''])[0]
@@ -426,7 +426,7 @@
         # only users which are allowed to delete should use this tool
         elif request.user.may.delete(pagename):
             # only POST continues
-            if not ensureversion(request, '1.9.0'):
+            if not ensureversion('1.9.0'):
                 if request.request_method != 'POST':
                     return _('Missing parameters or GET method used'), "error"
             else: